Troubleshoot Baseplate (Drawer) Detection Malfunction for xTool MetalFab CNC Cutter
Updated Jul 7,2025
Updated Jul 7,2025

Issue description

If XCS alerts that the baseplate (drawer) of your xTool MetalFab CNC Cutter is not placed properly and therefore prevents processing, please refer to this guide for troubleshooting.

Possible causes

  1. Improper baseplate installation: The baseplate is not fully inserted into the mian unit.
  2. Baseplate deformation: The baseplate is deformed, preventing itself from proper sensor contact.
  3. Sensor cable disconnection: The sensor cable is disconnected to the main control board.
  4. Sensor malfunction: The sensor may malfunction.
  5. Sensor connector malfunction: The sensor connector on the main control board may malfunction.

Troubleshooting flowchart

Detailed procedure

Step 1: Check the baseplate installation

  1. Ensure that the baseplate is fully inserted into the main unit without visible gaps.
  1. If this does not resolve the issue, proceeed to the next step.

Step 2: Check the sensor

  1. Remove the five screws and the back plate.
     
  2. To check whether the sensor works properly, turn on the machine and activate the sensor by either:
  • Pushing the nearest panel slightly towards the sensor
  • Placing a metal shim near the sensor
  1. Observe the sensor indicator status.
  • Normal operation: The red light turns ON when the panel/metal shim is near and OFF when it is moved away.
  • Malfunction: The indicator doesn't illuminate.

Red light OFF
/Indicator not illuminating

Red light ON

  1. If the sensor works properly, the issue may be caused by baseplate deformation or misalignment, preventing the baseplate from reaching the sensor. To resolve this:
  • Option 1: Loosen the two sensor screws and pull the sensor outwards a bit. Then, tighten the screws.

 

  • Option 2: Attach a 1 mm thick, 25 mm × 25 mm stainless steel shim (using adhesive tape) to the baseplate at the same height as the sensor.
  1. If the sensor indicator doesn't illuminate, proceed to the next step.

Step 3: Check the sensor cable connection

  1. Ensure that the machine is powered off, then remove the screws and the plate at the rear.
  1. Disconnect the sensor cable from the blue connector indicated by the red arrow.
  1. Restart the machine and check the sensor again.
  • If the sensor works properly, the issue is resolved.
  • If none of these steps resolve the unexpected detection issue, the sensor or its connector on the main control board may be malfunctioning. Please prepare a video recording your troubleshooting process and results and contact xTool Customer Service for further assistance.

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