Troubleshoot Software Failure after Firmware Upgrade
Updated Jun 2,2026
Updated Jun 2,2026

Issue description

The software may become unavailable on certain models after upgrading the firmware version.

  • Models: xTool F1; xTool F1 Lite; xTool F1 Ultra; xTool P2S; xTool M1 Ultra
  • Software: xTool Creative Space (Mobile and Desktop); LightBurn; xTool Studio (Version 1.6 and below)


Updated Firmware:

xTool F1: 40.51.020.04 or above.

xTool F1 Lite: 40.55.020.04 or above

xTool F1 Ultra (Class 4): 40.52.016.05 or above

xTool F1 Ultra (Class 1): 40.53.007.05 or above

xTool M1 Ultra: 40.41.017 or above

xTool P2S: V011


Downgraded Firmware:

xTool F1: 40.51.015.02

xTool F1 Lite: 40.55.003.02

xTool F1 Ultra (Class 4): 40.52.013.01.ht22

xTool F1 Ultra (Class 1): 40.53.005.01.ht5

xTool M1 Ultra: V40.41.016.2020.01

xTool P2S: 40.22.010.03


Possible cause

To provide more robust underlying system protection and keep pace with global trends in industrial equipment optimization, we have implemented a comprehensive upgrade to our communication protocols. LightBurn, XCS, and Studio versions below 1.6 are no longer supported.

Troubleshooting

You can resolve this issue by downgrading the firmware. The older firmware version is compatible with LightBurn, XCS, and Studio versions below 1.6. Here are the instructions for downgrading the firmware:

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