Troubleshoot "Exceptions Occur" (Error Code: M9039 S2) on xTool AP Series
Updated Nov 6,2025
Updated Nov 6,2025

Issue description

When AP2 works with an xTool laser machine that supports Bluetooth conectivity, the xTool software may prompt an error message with the error code M9039 S2 as shown in the following figure.

image.png

Potential causes

  • The filters are not properly installed.
  • The NFC card is not working

Troubleshooting procedures

Step 1: Check and re-install the filters

1) Check whether the five filters and the cyclone are installed in place.

img_v3_02ro_247ef536-9a45-45e1-bff9-952577803f2g.jpg

2) Check whether the filters are pushed all the way to the innermost.

image.png

Step 2: Check whether the NFC malfunctioning is causing the issue

The filter life is calculated via the NFC card inside AP2. If the NFC card is invalid, the filter life would be mistakenly displayed as 0, and the error code M9039 S2 would be reported as well.

On the xTool software, check whether any filter life is 0 as shown in the following figure. If yes, take a screenshot and contact technical support for solutions.

image.png

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