Issue description
If you cannot connect xTool MetalFab CNC Cutter to xTool software via Wi-Fi, please refer to this troubleshooting to solve the issue.
Possible causes
- Unsupported Device
- Antenna:
- Network:
- Incorrect setup
- Weak signal
- Not whitelisted in the router
Detailed procedure
Step 1: Check your connected device
xTool MetalFab CNC Cutter can only be connected to a computer and is not compatible with phones, tablets, or other mobile devices. Please ensure that xTool MetalFab CNC Cutter is connected to a computer.
Step 2: Check the antenna installation
- Refer to the following image and check if your antenna appearance is intact, with no signs of damage.
- If yes, follow the next step.
- If not, contact xTool Customer Service for further assistance.

- If the antenna is not damaged, ensure that it is properly installed at the rear of xTool MetalFab CNC Cutter.

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- Install the external antenna into the slot of the main unit.
| - Rotate the antenna clockwise.
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- Raise the end of the antenna.
| Done! |
- If the issue persists, proceed to the next step.
Step 3: Reconfigure the network
- Follow Operate xTool MetalFab CNC Cutter with XCS (V2.0) on Your Computer to connect xTool MetalFab CNC Cutter to xTool software via Wi-Fi.
- If the issue persists, proceed to the next step.
Step 4: Choose another network
- Connect both your computer and xTool MetalFab CNC Cutter to the same alternative network. You may:
- Option 1: Switch to a different Wi-Fi network.
- Option 2: Use your mobile phone's hotspot and connect both devices to it.
- If the issue persists, please prepare the following materials and send them to xTool Customer Service for further assistance:
- A video recording your troubleshooting process and results
- Work log of xTool MetalFab CNC Cutter

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