Issue description
During camera calibration with XCS, if an error message "Calibration failed. Please try again." pops up, please follow this troubleshooting guide to resolve this issue.

Possible Causes
- Slats related
- Excessive metal debris adheres to the slats.
- The slats are not fully seated in the slots, causing unevenness when the calibration plate is placed.
- Camera calibration board related
- The protective film is not removed.
- There are metal sheets under the board.
- The board is not placed at the target position.
- The board is not clamped with the left fixture, leading to the board displacement during machine calibration.
Troubleshooting procedure
Before Calibration
- Ensure that the slats are not attached with obvious metal debris.
If there is any, use an angle-grinder to sand the slats. Then, snap them back into the slots and ensure that the slats are level.

- Ensure that there are no metal sheets on the slats.
- Ensure that the protective film is peeled off from the camera calibration board. Then place the board onto the slats.

During calibration
- Ensure that the red spot falls on the target grid of the board.
- Use the left fixture to secure the board.

- Calibrate again. You may perform the calibration a few more times to see if the issue is resolved.
- If the issue persists, please prepare a video recording your troubleshooting process and results and contact xTool Customer Service for further assistance.
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