Troubleshoot macOS (15 or Above) Fails to Connect to xTool Device
Updated Nov 1,2024
Updated Nov 1,2024

Issue description

  • If you have a Mac computer running macOS version 15 or higher and are unable to connect to your xTool laser device, please refer to this troubleshooting guide for assistance.

đź’ˇNote: Connecting Mac computers to xTool engraver requires a USB 2.0 Type-C to Type-C cable.

 

Possible cause

When you operate xTool Creative Space (XCS) for the first time, a notification will prompt you to allow XCS to access local networks.

  • If the "Don’t Allow" is selected, XCS will be denied access to the machine.

  • To ensure a seamless connection, click on the "Allow" at this step.

 

Troubleshooting

#Check local network access for XCS

  • Go to Settings > Privacy & Security > Local Network.
  • Ensure that xTool Creative Space has network access; otherwise, the machine cannot connect to the computer.
    • If the local network access is disabled, toggle the switch to enable it, allowing the software to access your local network.

If the issue persists despite following the above steps, please contact xTool Customer Service at support@xtool.com. Include a detailed description of the issue and a list of the troubleshooting results you have already attempted to help us determine the appropriate course of action promptly.

 

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