Troubleshoot U-axis Driver Exception (Error Code: M23 S138) for M1 Ultra
Updated Nov 16,2024
Updated Nov 16,2024

Issue description

  • If xTool Creative Space (XCS) pops up an error message stating “U-axis driver exception (error code: M23 S138),” please follow this guide for troubleshooting.

 

Possible causes

  • Hot swapping (in most cases);
  • Connection failure in M1 Ultra's extension port(s);
  • Rotary Attachment 2 Pro (RA2 Pro) motor overheating;
  • RA2 Pro motor short circuit;
  • Connection issues between RA2 Pro and M1 Ultra;
  • Loose adapter cable connection to the main control board of RA2 Pro;

 

How to fix it

#1 Avoid hot swapping

  1. Power off: Turn off M1 Ultra and unplug its power cable.
  2. Reconnect RA2 Pro: Connect the RA2 Pro to the M1 Ultra and other intended accessories while the laser engraver is powered off.
  3. Power up: Reconnect M1 Ultra to its power cable with the RA2 Pro and other intended accessories connected. Turn on the M1 Ultra and check if the error code persists.
  4. Note on hot-swapping: Lab testing indicates that this issue is often ascribed to hot-swapping the RA2 Pro while the laser engraver is on standby. Hence, avoiding hot-swapping accessories is advisable.
  5. If this does not resolve the issue, proceed to the next step.

 

#2 Remove all accessories

  • Power off: Turn off the machine.
  • Disconnect cables: Remove all accessory cables, including the Rotary Attachment 2 Pro cable.
  • Reboot: Power on the machine to check if the error is still present.
  • Reconnect accessories: lf no error message pops up by now, reconnect the accessory's connection cable to a different extension port on the back of the M1 Ultra (not the previously occupied port) before rebooting the machine. Inspect the results:
    • If the error reoccurs after reconnecting accessories, the issue may be with the accessory connection cables or the accessories themselves. Use different cables for cross-testing to further identify the root cause.
    • If the error does not reoccur, the original extension port may be glitching. Contact xTool Customer Service for further assistance.
Extension Ports on the Back
Extension Port on the Front

Rotary Attachment errors: If the error only occurs when connecting Rotary Attachment, follow these steps:

  • Cool down RA2 Pro motor:
    • Power down: Turn off M1 Ultra for approximately 5 minutes.
    • Reboot and check: After the cooling period, reboot the machine and run XCS to check if the issue still pops up.
    • Temperature advisory: To prevent motor overheating, avoid operating the RA2 Pro in high-temperature environments.
    • If the issue persists, proceed to the next step.
  • Check RA2 Pro motor:
    • Power off: Turn off M1 Ultra.
    • Disconnect cable: Disconnect the cable from the RA2 Pro end while leaving the other end connected to the laser engraver.
    • Reboot and check: Reboot the laser engraver to check if the error message persists.
    • Error message disappears: If the error message disappears, this indicates a malfunction in the RA2 Pro motor. Please contact xTool Customer Service at support@xtool.com for further assistance.
    • Error message persists: If the error message persists, proceed to the next troubleshooting step.
  • Inspect RA2 Pro Cable:
    • Power off: Turn off the M1 Ultra.
    • Disconnect cable: Unplug the RA2 Pro cable from the M1 Ultra.
    • Reboot and check: Reboot the laser engraver to check if the error message persists.
    • Error message disappears: If the error message does not appear, this pins down the cause of this issue to a broken RA2 Pro connection cable. Replace the cable with a new one to resolve the issue.
    • Error message persists: If the error message continues, proceed to the next troubleshooting step.

Persisting errors: If errors persist after disconnecting all accessory cables, proceed to the next step.

 

#3 Secure the adaptor cable

  1. Power off: Turn off M1 Ultra and unplug its power cable.
  2. Remove the main control board shield: Follow the video tutorial below to detach the main control board shield (from 0:00 - 1:32). 
  3. Inspect cable connection: Check if the RA2 Pro adapter cable on M1 Ultra's main control board is loosely seated on its socket (refer to the image below).

    • If the cable is loose, reconnect it securely.
  4. Test the Connection: After replugging the RA2 Pro adapter cable on the main control board, if the error message persists, please endeavor to unplug this cable before rebooting the engraver to inspect for the error message.
    • If the error is resolved after unplugging the cable, this indicates a broken cable. Please contact xTool Customer Service to resolve this issue.
    • If the error still persists, it implies a potential short circuit of the cable socket on the main control board. Please contact xTool Customer Service to resolve this issue.

If the issue persists despite following the above steps, please contact xTool Customer Service at support@xtool.com. Include a detailed description of the issue and a list of the troubleshooting results you have already attempted for further assistance.

 

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