Troubleshoot "Safety lock locking exception" for xTool P2
Updated May 11,2026
Updated May 11,2026

Issue description

When this issue happens, the safety lock fails to lock into the hole in the lid.

If the device is connected with xTool Studio in the meantime, you may see a pop-up error message showing "Safety lock locking exception" like below.

Causes

  • Unmoved sticker
  • Deformed Lid
  • Foreign Object
  • Safety Lock Failure

Note

Tutorial: Control the safety lock 

Connect P2 or P2S with a USB cable, open the browser, input the link in the address bar, and press "Enter" to control the safety lock. (Test with the lid open is supported)

Solutions

1. Remove the sticker

Remove the sticker shown, as it will hinder the proper securing of the safety lock into the hole on the lid.

2. Check the lid

(1) If the lid is deformed or warped in any way that prevents it from fully closing, try to restore it.

 

(2) You can refer to the following video for adjustment. However, make sure to place a soft material underneath to avoid scratching the enclosure:

3. Check foreign objects

(1) Remove the left upper cover.

  P2: Remove the Casing of xTool P2 Laser Engraver

  P2S: Remove & Install the Left Plate for xTool P2S

(2) Check for any foreign objects and remove them.

4. Check the safety lock

Note: This method applies to the P2 and P2S running firmware version 010 or earlier. If you want to use this method on a P2S with a firmware version later than 010, please refer to this article to downgrade the firmware: Downgrade Firmware for xTool P2S in xTool Studio

(1) Refer to the tutorial in the note for guidance. Check if you can control the safety lock as intended.

(2) If not, check the mainboard cable:

  • Remove the left upper cover.

  P2: Remove the Casing of xTool P2 Laser Engraver

  P2S: Remove & Install the Left Plate for xTool P2S

  • Inspect the cables on the main control board for any signs of breakage, or unplug and reconnect the cables to make sure of a secure connection.

secure

Contact us

If none of the above works, the safety lock may be faulty.

Please record a video of the problem, gather the troubleshooting steps you have taken, and download the work log in the software, then get in touch with our xTool customer support team at support@xtool.com for further assistance.

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